Konuyu Paylaş : facebook gplus twitter

Konuyu Oyla:
  • Derecelendirme: 0/5 - 0 oy
  • 1
  • 2
  • 3
  • 4
  • 5
Datasnap Türkçe karakter sorunu [Çözüldü]
#1
Merhaba,

Datasnap metodu ile mysql veritabanına bağlanıp veri çekiyorum. Fakat türkçe karakter sorunu oluyor. 

Örneğin: osmanlı padişahları gibi bir yazıyı osmanl? padi?ahlar? gibi çekiyor.

Kullanılan companent ler sqlconnection ve sqlservermethod  bunların bu karakter sorununu nasıl çözebilirim

charsetleri bir türlü değiştiremiyorum.

aslında sqlconnection da sorun yok bence asıl sorun sqlservermethodta

yardımlarınız için çok teşekkür ederim şimdiden
Cevapla
#2
sunucu ve local de utf-8 kullandığınız sürece sorun olmaması gerekiyor
WWW
Cevapla
#3
hocam wampserver kullanıyorum mysql kısmında karakter sorunu yok. sqlconnection olsun servermethod olsun hiçbir şekilde charset değiştiremiyorum ya da görüntüleyemiyorum örnek kodu şu şekilde paylaşayım

Clientten gönderilen komut sonuçlar memoya yazdırlıyor
----------
ServerMethodMerhaba.CommandText:='TServerMethods1.MerhabaEchoString';
ServerMethodMerhaba.Params[0].AsString:='select soru from bilsoru where id='+char(39)+'1'+char(39);
ServerMethodMerhaba.ExecuteMethod ;
NeGeldi:= utf8encode(ServerMethodMerhaba.Params[1].AsString);
memo1.Text:=NeGeldi;

---------

Bu da server tarafı komutu alıp tekrar gönderiyor.

---------------

q1.Close ;
  q1.SQL.Clear ;

q1.SQL.Add(value);
 q1.open;

  sonuc:= q1.Fields[0].AsString ;
 Result :=sonuc;

---------
Cevapla
#4
Öncelikle server tarafında sonucu log'lamakta fayda var. Bunu kontrol ettiniz mi?
There's no place like 127.0.0.1
WWW
Cevapla
#5
(09-02-2018, Saat: 09:51)SimaWB Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Giriş yap veya Üye OlÖncelikle server tarafında sonucu log'lamakta fayda var. Bunu kontrol ettiniz mi?

bu fikri verdiğiniz için teşekkürler üstat. Bu sayede cliente değil de serverda problem olduğunu farkketim. Server'daki sqlconnection'ın charset'ini latin5 yaptım. Daha sonra wampserver daki mysql'i de latin1_turkish_ci olarak değiştirdim sorun çözüldü.  Serverdaki charset ile wampserver aynı olmalıymış.
Cevapla

Konuyu Paylaş : facebook gplus twitter



Konu ile Alakalı Benzer Konular
Konular Yazar Yorumlar Okunma Son Yorum
  Lisanslama Sorunu Hk. glagher 9 291 22-06-2018, Saat: 18:00
Son Yorum: 3ddark
  [ÇÖZÜLDÜ]-cxDBPivotGrid Seçili Satır Alan Değeri Alma hi_selamlar 2 96 21-06-2018, Saat: 10:40
Son Yorum: hi_selamlar
  Aes şifreleme sorunu seci20 3 163 18-06-2018, Saat: 11:45
Son Yorum: sadettinpolat
  RSA anahtarı hesaplama sorunu seci20 8 290 14-06-2018, Saat: 15:19
Son Yorum: seci20
  DbBrowser-Veritabanı kilitlenme sorunu ? BY-HAYALET 2 111 08-06-2018, Saat: 21:13
Son Yorum: BY-HAYALET



Konuyu Okuyanlar: 1 Ziyaretçi