Delphi Can
Emulatorde INSTALL_FAILED_NO_MATCHING_ABIS hatası - Baskı Önizleme

+- Delphi Can (http://www.delphican.com)
+-- Forum: Delphi (http://www.delphican.com/forumdisplay.php?fid=3)
+--- Forum: Mobil Platform - FireMonkey (FMX) (http://www.delphican.com/forumdisplay.php?fid=7)
+--- Konu Başlığı: Emulatorde INSTALL_FAILED_NO_MATCHING_ABIS hatası (/showthread.php?tid=2259)

Sayfalar: 1 2


Emulatorde INSTALL_FAILED_NO_MATCHING_ABIS hatası - ybelen - 23-05-2018

Merhaba projeyi android emulator üzerinde çalıştırmak istediğimde "INSTALL_FAILED_NO_MATCHING_ABIS: Failed to extract native libraries, res=-113" şeklinde hata alıyorum. Nasıl düzeltebilirim ?



oVQ3Do.png


Cvp: Emulatorde INSTALL_FAILED_NO_MATCHING_ABIS hatası - ihalilcoban - 23-05-2018

Sisteminizde adb driver yüklü mü? Değilse yüklemeniz gerekmektedir. Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız. ulaşabilirsiniz.


Cvp: Emulatorde INSTALL_FAILED_NO_MATCHING_ABIS hatası - Fesih ARSLAN - 23-05-2018

Merhaba,
Android platformu seçili iken, Project > Deployment manager penceresinin ekran görüntüsünü paylaşabilir misiniz?


Cvp: Emulatorde INSTALL_FAILED_NO_MATCHING_ABIS hatası - ybelen - 23-05-2018

(23-05-2018, Saat: 15:13)ihalilcoban Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.Sisteminizde adb driver yüklü mü? Değilse yüklemeniz gerekmektedir. Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız. ulaşabilirsiniz.

Yüklü değildi yükledim ama sorun devam ediyor

(23-05-2018, Saat: 15:18)Fesih ARSLAN Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.Merhaba,
Android platformu seçili iken, Project > Deployment manager penceresinin ekran görüntüsünü paylaşabilir misiniz?

Fesih Bey ekran görüntüsü bu şekilde : 



aYqXNd.png


Cvp: Emulatorde INSTALL_FAILED_NO_MATCHING_ABIS hatası - Fesih ARSLAN - 23-05-2018

Deployment konfigürasyonunda herhangi bir sorun görünmüyor. 
Tahminimce AVD Manager aracılığıyla oluşturduğunuz sistem image'ında bir sorun olabilir.  
1- Android Sistem Image'ını (Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.) yeniden yükleyin.
2- AVD Manager penceresinde daha önce oluşturduğunuz emülatörü silin.
3- Yeni Image ile emülatörü yeniden oluşturun.


Cvp: Emulatorde INSTALL_FAILED_NO_MATCHING_ABIS hatası - ybelen - 23-05-2018

(23-05-2018, Saat: 17:41)Fesih ARSLAN Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.Deployment konfigürasyonunda herhangi bir sorun görünmüyor. 
Tahminimce AVD Manager aracılığıyla oluşturduğunuz sistem image'ında bir sorun olabilir.  
1- Android Sistem Image'ını (Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.) yeniden yükleyin.
2- AVD Manager penceresinde daha önce oluşturduğunuz emülatörü silin.
3- Yeni Image ile emülatörü yeniden oluşturun.

Fesih Bey dediklerinizi yaptım sorun düzelmedi. 
AVD manager üzerinden CPU seçimini ARM(armeabi-v7a) seçince çalıştı. CPU olarak intel kullanamıyor muyuz ?


Cvp: Emulatorde INSTALL_FAILED_NO_MATCHING_ABIS hatası - Fesih ARSLAN - 24-05-2018

(23-05-2018, Saat: 23:19)ybelen Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.
(23-05-2018, Saat: 17:41)Fesih ARSLAN Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.Deployment konfigürasyonunda herhangi bir sorun görünmüyor. 
Tahminimce AVD Manager aracılığıyla oluşturduğunuz sistem image'ında bir sorun olabilir.  
1- Android Sistem Image'ını (Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.) yeniden yükleyin.
2- AVD Manager penceresinde daha önce oluşturduğunuz emülatörü silin.
3- Yeni Image ile emülatörü yeniden oluşturun.

Fesih Bey dediklerinizi yaptım sorun düzelmedi. 
AVD manager üzerinden CPU seçimini ARM(armeabi-v7a) seçince çalıştı. CPU olarak intel kullanamıyor muyuz ?

Yaptığınız işlem dediklerim arasında vardı (1. Adım örnek linki)
Kullandığınız API level'e uygun bir x86 image yüklerin. Emulator oluştururken de x86 image'ınızı seçin.
Ayrıca Delphi 10 ve altı bir sürüm için Deployment manager'da küçük bir konfigürasyon yapmanız gerekecek.


Cvp: Emulatorde INSTALL_FAILED_NO_MATCHING_ABIS hatası - ybelen - 26-05-2018

(24-05-2018, Saat: 02:09)Fesih ARSLAN Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.
(23-05-2018, Saat: 23:19)ybelen Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.Fesih Bey dediklerinizi yaptım sorun düzelmedi. 
AVD manager üzerinden CPU seçimini ARM(armeabi-v7a) seçince çalıştı. CPU olarak intel kullanamıyor muyuz ?

Yaptığınız işlem dediklerim arasında vardı (1. Adım örnek linki)
Kullandığınız API level'e uygun bir x86 image yüklerin. Emulator oluştururken de x86 image'ınızı seçin.
Ayrıca Delphi 10 ve altı bir sürüm için Deployment manager'da küçük bir konfigürasyon yapmanız gerekecek.

Merhaba, 

Dediğiniz gibi x86 yükledim. Deployment manager için nasıl bir ayarlama yapmam gerekiyor


Cvp: Emulatorde INSTALL_FAILED_NO_MATCHING_ABIS hatası - Halil Han Badem - 26-05-2018

(26-05-2018, Saat: 12:37)ybelen Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.
(24-05-2018, Saat: 02:09)Fesih ARSLAN Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.Yaptığınız işlem dediklerim arasında vardı (1. Adım örnek linki)
Kullandığınız API level'e uygun bir x86 image yüklerin. Emulator oluştururken de x86 image'ınızı seçin.
Ayrıca Delphi 10 ve altı bir sürüm için Deployment manager'da küçük bir konfigürasyon yapmanız gerekecek.

Merhaba, 

Dediğiniz gibi x86 yükledim. Deployment manager için nasıl bir ayarlama yapmam gerekiyor

 Yanlış değilsem libnative.so tiklerini kaldırmak gerekiyor. Eğer @Fesih ARSLAN hocamın dediği olay libnative ise; bunun için bir videom vardı. Intel işlemciler için geçmişte sorun yaşamıştım ve sonuç olarak bu çözümü vermişlerdi. Attığım video kaynaklarını inceleyerek bir fixleme yaparsanız daha sağlıklı sonuç elde edersiniz demiş sanırsam Fesih hocam.

Video:

Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.

Yazılı Kaynak[Marco reis yazmış]:

Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.

Kolay gelsin.


Cvp: Emulatorde INSTALL_FAILED_NO_MATCHING_ABIS hatası - ybelen - 29-05-2018

(26-05-2018, Saat: 23:57)hyperxman Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.
(26-05-2018, Saat: 12:37)ybelen Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.Merhaba, 

Dediğiniz gibi x86 yükledim. Deployment manager için nasıl bir ayarlama yapmam gerekiyor

 Yanlış değilsem libnative.so tiklerini kaldırmak gerekiyor. Eğer @Fesih ARSLAN hocamın dediği olay libnative ise; bunun için bir videom vardı. Intel işlemciler için geçmişte sorun yaşamıştım ve sonuç olarak bu çözümü vermişlerdi. Attığım video kaynaklarını inceleyerek bir fixleme yaparsanız daha sağlıklı sonuç elde edersiniz demiş sanırsam Fesih hocam.

Video:

Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.

Yazılı Kaynak[Marco reis yazmış]:

Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.

Kolay gelsin.

Merhaba hocam,

Videonuzu daha önceden izlemiştim fakat yine çözüm olmadı. Deployment kısmında x86 ya ait bir tanım bulunmuyor. Sorun bundan kaynaklanıyor oalbilir mi ? qv9VMR.png