Konuyu Oyla:
  • Derecelendirme: 4/5 - 1 oy
  • 1
  • 2
  • 3
  • 4
  • 5
Delphi 2010 ?
#1
Question 
Merhaba arkadaşlar,

çok uzun zamandır (yaklaşık 6 yıldır) delphi 2010 sürümünü kullanmaktayım. Çalıştığım şirketin otomasyon yazılımlarına yönelik ihtiyaçlarını / geliştirmelerini 2010 sürüm ile yapmaktayım. Sizce daha üst bir sürüme geçmelimiyim ? DevExpress,Jedi,Alpha ve TMS componentleri kullanıyorum. Sürüm yükseltmem durumunda bunların tümünü sağlıklı bir şekilde yeniden yükleyip kullanabilecekmiyim ondanda çok emin değilim açıkcası. Sormamın sebebi Windows 10 a yönelik yaşamaya başladığım bazı sıkıntılar. Bu konuda görüşlerinizi ve önerilerinizi paylaşırsanız sevinirim.
Cevapla
#2
2010 unicode olduğundan bence sıkıntı yaşamaz hatta verim alırsınız.
Saygılarımla
Muharrem ARMAN

guplouajuixjzfm15eqb.gif


Cevapla
#3
Merhaba,
Bahsetmiş olduğunuz tüm harici bileşen setleri Delphi'nin mevcut sürümünü desteklemektedir. 
Geçiş aşamasında yaşadığınız sorun veya hatalarda biz DelphiCan'lar devreye girer el birliğiyle düzeltiriz.
Bir zaman Delphi 4 projesini, Delphi XE sürümüne geçirmiştik. @mrmarman ın da belirttiği gibi Delphi 2010 üzerinde çalışan bir projenin Delphi 10.2'ye geçirilmesi hiç de zor olmayacaktır.
While true do; Hayat döngüsü, kısır değildir! Yapılan bir yanlış, o döngünün dışına çıkmanızı sağlayacaktır.
WWW
Cevapla
#4
(31-08-2018, Saat: 15:20)Fesih ARSLAN Adlı Kullanıcıdan Alıntı: Merhaba,
Bahsetmiş olduğunuz tüm harici bileşen setleri Delphi'nin mevcut sürümünü desteklemektedir. 
Geçiş aşamasında yaşadığınız sorun veya hatalarda biz DelphiCan'lar devreye girer el birliğiyle düzeltiriz.
Bir zaman Delphi 4 projesini, Delphi XE sürümüne geçirmiştik. @mrmarman ın da belirttiği gibi Delphi 2010 üzerinde çalışan bir projenin Delphi 10.2'ye geçirilmesi hiç de zor olmayacaktır.


10.2 kurup deneyeceğim takıldığım noktalarda uygun bölüme konuyu açarım. Kurulumlardan ziyade proje uyumluluğu konusunda çok sorun yaşayacağımı düşünüyorum ama sizlerinde yardımıyla üstesinden geliriz diye umuyorum. Teşekkür ediyorum ilginiz için

(31-08-2018, Saat: 15:20)Fesih ARSLAN Adlı Kullanıcıdan Alıntı: Merhaba,
Bahsetmiş olduğunuz tüm harici bileşen setleri Delphi'nin mevcut sürümünü desteklemektedir. 
Geçiş aşamasında yaşadığınız sorun veya hatalarda biz DelphiCan'lar devreye girer el birliğiyle düzeltiriz.
Bir zaman Delphi 4 projesini, Delphi XE sürümüne geçirmiştik. @mrmarman ın da belirttiği gibi Delphi 2010 üzerinde çalışan bir projenin Delphi 10.2'ye geçirilmesi hiç de zor olmayacaktır.

En son 10.2 sürümü bu mudur ?

Embarcadero RAD Studio 10.2.3 Tokyo Architect
Cevapla
#5
(31-08-2018, Saat: 15:30)Dereck Adlı Kullanıcıdan Alıntı: En son 10.2 sürümü bu mudur ?

Embarcadero RAD Studio 10.2.3 Tokyo Architect

Evet. Lisansınız var ise en gelişmiş sürümü Architect'tir. Lisansınız yoksa bir yıllık Delphi 10.2.3 Community sürümünü 5.000 dolara kadar ücretsiz kullanabilirsiniz.
While true do; Hayat döngüsü, kısır değildir! Yapılan bir yanlış, o döngünün dışına çıkmanızı sağlayacaktır.
WWW
Cevapla




Konuyu Okuyanlar: 1 Ziyaretçi