Konuyu Oyla:
  • Derecelendirme: 0/5 - 0 oy
  • 1
  • 2
  • 3
  • 4
  • 5
Embarcadero sensör örnekleri çalışmıyor
#11
(13-09-2018, Saat: 09:16)mrmarman Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.SDK Manager API 27 yüklerken NDK daki And27 klasörü de birlikte otomatik kurulması lazım. Birden fazla ndk sürümü kurulumunuz varsa bilgisayarda atama yaptırın isterseniz.

arama anahtarınız "android-27" bakalım kaç farklı klasörde çıkacak (tabii kurulum loglarınıza da bakabilirsiniz)
Merhaba.
SDK manager api 27 yüklerken NDK aynı kaldı otomatik yuklemedi ve bende siteden kendim indirip dizine attım ve calistirmiyor. NDK 9c ve NDK r17c olarak iki surum var r17c yi kendim atmistim dizine. NDK 9c de ise android 27 yok 19 a kada4 var.Sizin dediğiniz gibi otomatik yüklemesi gerekiyorsa baştan yapmam gerek. Cevabiniz icin teşekkür ederim.
Cevapla
#12
Merhaba. Aradan geçen yaklaşık 2 hafta NDK güncellemesi için çeşitli yöntemleri deneye deneye geçti. Delphi Tokyo Community sürümünü kullanıyorum. SDK güncellemesi yapmasını istediğimde NDK yı güncellememişti. PRogramı tümden silip tekrar temiz bir kurulum yaptım aynı hatayı verdi. Tekrar silip kurarken SDK manager ve NDK r9c yükle kısmını seçmeden yükledim, amacım daha sonra kendim sürümü seçmek istememdi ancak android sdk seçebileceğim bir sdk manager vb bir araç karşıma çıkmadı.

Bende ki varsayılan SDK dizini C:\Users\Public\Documents\Embarcadero\Studio\19.0\CatalogRepository\

Sayın mrmarman Beyin çözüm için verdiği ki tekrar kendisine teşekkür ediyorum ve çözümüne ulaşmak için baya uğraştım Smile paylaşım dizini C:\ArmanStudy\PlatformSDKs\android-ndk-r16b\Platforms\android-27

diyerek android-ndk-r16b sürümünü ve SDK 25.2.5 sürümünü yükseltmem gerek diye rad studio izin vermedikçe alternatif yollar aradım. SDK Managerdan SDK manager 25.2.5 yükselttiğimde yine varsayılan olarak kurulan 24 sürrümünde kaldı. NDK yine yükselmedi.

En son Tokyo sürümü bu şekilde bana izin vermiyor diyerek berlin sürümünü kurdum. Dizinleri ayarladım. SDK manager 25.2.5 sürümünü başarılı şekilde kurdum. Doğrudan Api 27 yi indirdim. Maalesef NDK yine r9c varsayılan olarak aynı duruyor gördüm. SDK manager nasılsa 25.2.5 diyerek 64 bit 32 bit ayrı ayrı google developer ilgili siteden Api 27 güncellemesi ile gelen r16b sürümünü 32 ve 64 bit sürümlerini ayrı ayrı indirdim. Manuel olarak SDK ve NDK ekleme seçeneğinden  eklemek istediğimde SDK yı kabul edip NDK yı kabul etmedi.

ndkhata.jpg

Embercadero SDK ve NDK için doğrudan indirme linkleri yok. NDK yı nasıl güncelleyebilirim?

Anlatımımın düzensizliği ve bozukluğu için kusuruma bakmayın. Zihnim yorgun ve hemen sorayım istedim.
Cevapla


Konu ile Alakalı Benzer Konular
Konular Yazar Yorumlar Okunma Son Yorum
  NOTE 3 ÇALIŞAN program üst sürümlerde çalışmıyor delhici 1 117 21-07-2019, Saat: 14:33
Son Yorum: Fesih ARSLAN
  NoxPlayer emulatörde çalışan uygulama store'de nindirildiğinde çalışmıyor. pro_imaj 1 258 24-03-2019, Saat: 04:16
Son Yorum: barox
  Location Sensor - Konum Bilgisi Öğrenme samet 4 1.069 11-09-2018, Saat: 10:45
Son Yorum: narkotik
  TCamera Component Çalışmıyor pro_imaj 6 1.008 11-02-2018, Saat: 01:12
Son Yorum: Lord_Ares
  Android Cihazda Debug Çalışmıyor nehirnnn 13 2.832 20-10-2017, Saat: 13:01
Son Yorum: nehirnnn



Konuyu Okuyanlar: 1 Ziyaretçi