Konuyu Oyla:
  • Derecelendirme: 5/5 - 1 oy
  • 1
  • 2
  • 3
  • 4
  • 5
IOS SDK versiyonları
#1
Wink 
Merhaba arkadaşlar.
FMX IOS geliştirirken, Simulator ve Telefon da hangi SDK sürümlerini kullanıyor sunuz? herhangi bir sürüm GB'lar boyutunda olduğu için ABD'yi yeniden keşfetmeyelim dedim ..
// Bilgi paylaştıkça çoğalır.. 

Cevapla
#2
Merhaba,
Yavaş yavaş Android testlerinden sonra birçok arkadaşın artık iOS'a yöneldiğini görüyoruz. 
Apple Store üzerinde uygulama yayınlamak, maalesef Google Play kadar kolay ve kontrolsüz değil. Bu anlamda sabırlı olmanızı diliyorum.
Yayınlama onay sürecinde her ne kadar Apple kontrolörlerine kızsanız da, sizin daha iyi bir proje ile kendinizi tanıtmanıza ve kendinizi daha iyi geliştirerek, profesyonel uygulama geliştirme yolunda ilerlememize yardımcı oldukları muhakkaktır.
Bunu zaman geçtikçe daha iyi anlamaya başladım.

Kombinasyon olarak iki yöntem öneriyorum.
I. Kombinasyon:
Delphi 10.1 (U2 veya hotfix kurulumlu) veya daha üstü + MacOS 10.13 High Sierra + Xcode 8.2 (iOS 10.2 içermektedir) 

II. Kombinasyon:
Delphi 10.3 + MacOS 10.14 Mojave + Xcode 10 (iOS 12 içermektedir) 
Bildiğiniz gibi iOS 11 ve daha üst sürümlerde simulator 64 bit üzerinde stabil çalışmaktadır. Delphi'nin henüz MacOS 64 bit desteği olmadığı için bu kombinasyonda simulator üzerinde proje çalıştıramıyoruz. Fiziksel cihaz üzerinde testler yapmanız gerekecektir.
While true do; Hayat döngüsü, kısır değildir! Yapılan bir yanlış, o döngünün dışına çıkmanızı sağlayacaktır.
WWW
Cevapla
#3
Android'den sonra IOS artık mecburi oldu gibi Hocam.

Bende Tokyo ve Rio sürümleri mevcut.
Fakat macbook pro'm eski 2011 i7.. Majove kurulamıyor.

Elimdeki mevcutlar:

macOS High Sierra 10.13.6
Xcode 10.1 (IOS SDK 12.1 standart geldi ve Manuel 8.1 indirdim.)..
Tokyo 10.2.1 ve Rio 10.3
// Bilgi paylaştıkça çoğalır.. 

Cevapla
#4
@Fesih ARSLAN Hocam Bende görünen Cihaz kısmında versiyon IOS SDK 12.1 görünüyor.. Bendeki cihaz 11.0 .. Sanırım bunu için cihazda uygulama açılış esnasında kapama veriyor.. IOS SDK'da cihazın SDK süümünü nasıl düşürebiliryoruz? Bu konuda çok cahilim.. Rolleyes Confused Dodgy
// Bilgi paylaştıkça çoğalır.. 

Cevapla
#5
uygulama cihaza yükleniyor ama hemen kapanıyorsa, apple developer sertifikalarında sorun olabilir
Cevapla
#6
(15-12-2018, Saat: 14:42)mcuyan Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.@Fesih ARSLAN Hocam Bende görünen Cihaz kısmında versiyon IOS SDK 12.1 görünüyor.. Bendeki cihaz 11.0 .. Sanırım bunu için cihazda uygulama açılış esnasında kapama veriyor.. IOS SDK'da cihazın SDK süümünü nasıl düşürebiliryoruz? Bu konuda çok cahilim.. Rolleyes Confused Dodgy

Ben o sorunu Fesih beyin tavsiyesiyle en baştan macOS sürümünü tekrar temiz yükleyip XCODE sürümünü dusurmustum
Cevapla
#7
Şimdi Xcode 8.3.3 indirip deneyceğim.. Araştırmalarıma göre olacak gibi bu sefer Smile
// Bilgi paylaştıkça çoğalır.. 

Cevapla
#8
(15-12-2018, Saat: 13:20)mcuyan Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.Android'den sonra IOS artık mecburi oldu gibi Hocam.

Bende Tokyo ve Rio sürümleri mevcut.
Fakat macbook pro'm eski 2011 i7.. Majove kurulamıyor.

Elimdeki mevcutlar:

macOS High Sierra 10.13.6
Xcode 10.1 (IOS SDK 12.1 standart geldi ve Manuel 8.1 indirdim.)..
Tokyo 10.2.1 ve Rio 10.3

Fiziksel MacOS bilgisayarla çalışmak oldukça zor olacaktır. Uyuşmazlıklarda, yeniden kurulum gerektirebilir.
Sanal MacOS tavsiye ederim. Snapshoot'larla istediğiniz temiz bir konfigürasyona çok hızlı bir şekilde geri dönebilirsiniz.
Xcode 10.1 iOS 12.1 SDK sürümünü içerir. Delphi'nin henüz iOS 12.1 SDK desteği yok.

(15-12-2018, Saat: 14:42)mcuyan Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.@Fesih ARSLAN Hocam Bende görünen Cihaz kısmında versiyon IOS SDK 12.1 görünüyor.. Bendeki cihaz 11.0 .. Sanırım bunu için cihazda uygulama açılış esnasında kapama veriyor.. IOS SDK'da cihazın SDK süümünü nasıl düşürebiliryoruz? Bu konuda çok cahilim.. Rolleyes Confused Dodgy

Kapanma, iOS 12.1 SDK sürümünden dolayıdır. Öncelikle iOS 12'yi deneyiniz. Olmaz ise fiziksel cihazı downgrade etmeniz gerektirebilir.

(15-12-2018, Saat: 20:59)mcuyan Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.Şimdi Xcode 8.3.3 indirip deneyceğim.. Araştırmalarıma göre olacak gibi bu sefer Smile

Mojave ve Tokyo kullancak olursanız bu Xcode yine desteklemez.
Bunu High Sierra üzerine kurar ve Tokyo kullanırsanız çalışır.
While true do; Hayat döngüsü, kısır değildir! Yapılan bir yanlış, o döngünün dışına çıkmanızı sağlayacaktır.
WWW
Cevapla
#9
Rio versiyon 12.1 de sorun yok şuan ama yeni versiyona geçmeye korkuyorum.
Cevapla




Konuyu Okuyanlar: 1 Ziyaretçi