Konuyu Oyla:
  • Derecelendirme: 0/5 - 0 oy
  • 1
  • 2
  • 3
  • 4
  • 5
Android 7.1.1 Null Pointer
#1
Merhaba,
Android 7.1.1'e proje derlendiğinde FMX ile aşağıdaki resimdeki hata alınmaktadır. Hata hakkında tecrübesi olanlar varsa yardımlarını beklemekteyim.

Cihaz ve Proje Bilgileri

Bilinmeyen kaynakları yükle açık.
Sıfır proje tek satır kod yok, yeni proje açılıp derleniyor hata alınıyor.
Hiçbir yetki yok default yetkiler dahi kapatıldı.
SDK Manager güncellemeler tamam.
Delphi 10.2.3 Tokyo -  Delphi 10.3.1 Rio boş proje test edildi ikisindede aynı hata.
Tablet modeli Exper EasyPad7 

anq8nd.png

jqJrqg.png
Yalnızım ama bir kente yürüyen ordu gibiyim, edebiyattan kaçınmalıyım..
Cevapla
#2
SDK Manager güncellemeler niye yapıyorsun ben kurulduğu gibi kullanıyorum
Cevapla
#3
(28-05-2019, Saat: 18:19)nguzeller Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.SDK Manager güncellemeler niye yapıyorsun ben kurulduğu gibi kullanıyorum

Test amaçlı farklı SDKlarda denedim
Yalnızım ama bir kente yürüyen ordu gibiyim, edebiyattan kaçınmalıyım..
Cevapla
#4
Hocam NDK ve Java kısımlarını da paylaşır mısınız ?

Eğer yanlış bilmiyorsam ;

En alttaki SDK API -Level Location kısmı desteklenen maksimum android sürümünü temsil etmekte.
Dolayısı ile sizin kullanmış olduğunuz SDK'lar android 22 düzeyinde fakat test ettiğiniz cihaz, bildirim de görünen logoya bakılırsa Android Nougat yani 24 -25 düzeylerinde.
SDK'ları daima en yüksekte tutmakta fayda var demekte sanırım yanlış olmaz.

   

Nitekim kendi yayında olan uygulamalarım da bile Min ve Max SDK sürümlerini 18 - 29 Düzeylerinde tutuyorum. resmi olarak 29 Versiyonu yok ama Kafa rahat olsun  Smile
Hayat bakış açına göredir ; Baktığında gördüğün görmeni istedikleridir...
Cevapla
#5
(29-05-2019, Saat: 09:44)Mr.Developer Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.Hocam NDK ve Java kısımlarını da paylaşır mısınız ?

Eğer yanlış bilmiyorsam ;

En alttaki SDK API -Level Location kısmı desteklenen maksimum android sürümünü temsil etmekte.
Dolayısı ile sizin kullanmış olduğunuz SDK'lar android 22 düzeyinde fakat test ettiğiniz cihaz, bildirim de görünen logoya bakılırsa Android Nougat yani 24 -25 düzeylerinde.
SDK'ları daima en yüksekte tutmakta fayda var demekte sanırım yanlış olmaz.



Nitekim kendi yayında olan uygulamalarım da bile Min ve Max SDK sürümlerini 18 - 29 Düzeylerinde tutuyorum. resmi olarak 29 Versiyonu yok ama Kafa rahat olsun  Smile

Öncelikle Teşekkürler, Api 28 ile de test ettim sonuç negatif
Yalnızım ama bir kente yürüyen ordu gibiyim, edebiyattan kaçınmalıyım..
Cevapla
#6
(29-05-2019, Saat: 10:47)narkotik Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.
(29-05-2019, Saat: 09:44)Mr.Developer Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.Hocam NDK ve Java kısımlarını da paylaşır mısınız ?

Eğer yanlış bilmiyorsam ;

En alttaki SDK API -Level Location kısmı desteklenen maksimum android sürümünü temsil etmekte.
Dolayısı ile sizin kullanmış olduğunuz SDK'lar android 22 düzeyinde fakat test ettiğiniz cihaz, bildirim de görünen logoya bakılırsa Android Nougat yani 24 -25 düzeylerinde.
SDK'ları daima en yüksekte tutmakta fayda var demekte sanırım yanlış olmaz.



Nitekim kendi yayında olan uygulamalarım da bile Min ve Max SDK sürümlerini 18 - 29 Düzeylerinde tutuyorum. resmi olarak 29 Versiyonu yok ama Kafa rahat olsun  Smile

Öncelikle Teşekkürler, Api 28 ile de test ettim sonuç negatif

Elden başka birşey gelmiyor mağlesef hocam Shy
Bu arada android sürümünüzü yazdığınızı yeni fark ettim unutkanlık cidden başa bela. Sad
Hayat bakış açına göredir ; Baktığında gördüğün görmeni istedikleridir...
Cevapla
#7
Merhabalar. Sürüm 28 ve 29 skları indirip tanımlamama rağmen apk derlemesinde neden 26 olarak güncellenir? Bu yüzden play store a atamıyorum apk yı? Yardımcı olur musunuz?
Cevapla
#8
(20-09-2019, Saat: 12:19)cihankoca Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.Merhabalar. Sürüm 28 ve 29 skları indirip tanımlamama rağmen apk derlemesinde neden 26 olarak güncellenir? Bu yüzden play store a atamıyorum apk yı? Yardımcı olur musunuz?

Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.  Smile

Ve ilk defa uygulama yükleyecekseniz ve hayati bir uygulama değil ise şimdilik yüklemeye çalışmayın derim. Delphi 10.4 gelene kadar yükleme yapmak için uğraştırıcı bir yol izlemeniz gerekiyor.  gerekli konularLinkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız. kısmında yer alıyor.
Hayat bakış açına göredir ; Baktığında gördüğün görmeni istedikleridir...
Cevapla


Konu ile Alakalı Benzer Konular
Konular Yazar Yorumlar Okunma Son Yorum
  Delphi 10.3 Android Servis Çalışma Sorunu Halil Han Badem 8 1.112 19-10-2019, Saat: 23:41
Son Yorum: malitutuncu
  Android SDK Manager Güncellemeleri dnzmobile 11 1.990 29-09-2019, Saat: 20:58
Son Yorum: serdar
  Android 7 - android 9 cihankoca 10 391 26-09-2019, Saat: 11:49
Son Yorum: cihankoca
  Android read_contacts izini sorunu [COZULDU] codder71 3 189 25-09-2019, Saat: 22:32
Son Yorum: codder71
  Android Sdk Güncellemesi cihankoca 4 237 23-09-2019, Saat: 11:45
Son Yorum: mcuyan



Konuyu Okuyanlar: 1 Ziyaretçi