Konuyu Oyla:
  • Derecelendirme: 4.67/5 - 3 oy
  • 1
  • 2
  • 3
  • 4
  • 5
Sdk Hatası
#21
(15-01-2017, Saat: 22:45)AbdullahB Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.Yaptığım araştırmalar sonucunda tam manası ile bir çözüme ulaşamadım fakat bir adım yol kat ettim galiba.

Usb ile telefonu bağlayarak projeyi çalıştırmayı 2 telefonda denedim. Biri Android sürümü 7. küsür bir telefon. Projeyi derlediğimde bu telefonda sorunsuz çalışıyor.

Diğer bir telefon ise galaxy s3 mini (Android sürümü: 4.2.2) bunda ise ne usb ile bağlayınca ne de apk dosyasını atınca çalışıyor.

Bu da gösteriyor ki android sürümü ile ilgili bir versiyon uyuşmazlığı var.

Yaptığım araştırmalar sonucunda AndroidManifest.xml dosyalarına girerek çeşitli ayarlamalar yaparak bunun çözülebileceği gibi bilgilere eriştim. Ve  <uses-sdk android:minSdkVersion="14" android:targetSdkVersion="14" /> gibi bir satır var  versiyon ile alakalı. Bunları değiştiriyorum ama başarılı sonuç alamıyorum. 

Örneğin herhangi bir telefonda 4.2.2 sürüm android olan için bunun karşılığı 17 yazıyorum ve derliyorum ya derlenirken kendiliğinden değişiyor ya da  hiç bir değişiklik olmuyor.

Bu konuda bilgisi olanlardan yardım bekliyorum. Androidin hemen hemen tüm sürümlerinde bir projeyi çalıştırabilmek için ne yapmak gerekir.

image10.png

SDK manager ile api 14,15,16,17,18 için olan sdklardan biri yüklü mü diye kontrol ettiğiniz de yüklü değilse yükleyip deneyin eğer yüklü ise yine 4.2.2 emulatoru veya 4.2.2 sahip cihazı takıp boş bir proje derleyip sonucu görmek gerek eğer boş projeyi calistiriyorsa kodlarinizi kontrol etmenizde yarar var .
Cevapla
#22
   

   

Yukarıdaki ekran alıntılarında olduğu gibi yüklü olanlar bu şekilde. Boş bir uygulamayı aynı şekilde çalıştırmak istediğimde yine 4.2.2 de çalışmadan kapanıyor ama başka telefonda açılabiliyor.
Başka ne gibi bir çözüm yolu izleyebilirim.

MinSdkVersion nasıl ayarlayabilrim ve bu çözüm olur mu?
Cevapla
#23
Merhaba hangi android versiyonu indirmeliyiz. Üst sürüm al sürümü destekliyor mu ?.   Örneğin Android 6 versiyonunu indirsek uygulamamız sadece 6 versiyonu çalıştıran telefonlarda mı çalışacak. Sürümü 4 veya 7 olanlarda çalışmayacak mı ? Yoksa 4 sürümünden başlayarak son sürüme kadar hepsini indirmek zorundamıyız..


attachment.php?aid=76
Cevapla
#24
(30-01-2019, Saat: 12:55)CesuR Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.Merhaba hangi android versiyonu indirmeliyiz. Üst sürüm al sürümü destekliyor mu ?.   Örneğin Android 6 versiyonunu indirsek uygulamamız sadece 6 versiyonu çalıştıran telefonlarda mı çalışacak. Sürümü 4 veya 7 olanlarda çalışmayacak mı ? Yoksa 4 sürümünden başlayarak son sürüme kadar hepsini indirmek zorundamıyız..
Merhaba,
Bu konu başlığında yazdığım Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız. zorunlu olan paketleri yazmıştım.
Üst sürümlerde çalışmaz. Aktif SDK ve alt sürümlerde çalışır.
While true do; Hayat döngüsü, kısır değildir! Yapılan bir yanlış, o döngünün dışına çıkmanızı sağlayacaktır.
WWW
Cevapla
#25
Cevabınıza göre anladığım  android 8.1  ve sdk içinde 28 sürümünü tek başına indirmek yeterli. Herbir android sürümünü indirmeye gerek yok. Üst sürüm olduğu için Android 7-6-5-4 sürümlü cihazlarda çalışır. Cevabınızda " SDK Platform ve ARM EABI v7a System Image seçin " demişsiniz fakat android 7 üstü versiyonlarda ARM EABI yok ?

7a6GGa.png
Cevapla
#26
(30-01-2019, Saat: 15:11)CesuR Adlı Kullanıcıdan Alıntı: Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız.Cevabınıza göre anladığım  android 8.1  ve sdk içinde 28 sürümünü tek başına indirmek yeterli. Herbir android sürümünü indirmeye gerek yok. Üst sürüm olduğu için Android 7-6-5-4 sürümlü cihazlarda çalışır. Cevabınızda " SDK Platform ve ARM EABI v7a System Image seçin " demişsiniz fakat android 7 üstü versiyonlarda ARM EABI yok ?

Haklısınız. Belirtiğiniz kalıplar Android sistem image'larıdır. Delphi 10.2 sürümünden sonra (10.2.1 - 10.2.2, 10.2.3 ve 10.3) Android emulator desteği vermeyeceğini açıklamıştı. 
Haliyle bu seçenek yorumu yazdığım dönemde ve şu anki alt sürümlerde (Delphi 10.2) halen geçerliğini sürdürürken, yeni sürümler için bu seçeneğe ihtiyaç yoktur. 
Emulator kullanacak iseniz daha önce @Mr.Developer ın açtığı Linkleri Görebilmeniz İçin Üye Olmanız Gerekiyor. Üye Olabilmek İçin Lütfen Buraya Tıklayınız. konu eminim faydalı olacaktır.
While true do; Hayat döngüsü, kısır değildir! Yapılan bir yanlış, o döngünün dışına çıkmanızı sağlayacaktır.
WWW
Cevapla


Konu ile Alakalı Benzer Konular
Konular Yazar Yorumlar Okunma Son Yorum
  Google Play Store'a Uygulama Yükme Hatası glagher 4 242 31-07-2019, Saat: 10:37
Son Yorum: Mr.Developer
  install_failed_older_sdk hatası cinarbil 2 192 27-07-2019, Saat: 14:03
Son Yorum: cinarbil
  Read-Only Hatası arsl01 8 381 15-06-2019, Saat: 16:08
Son Yorum: sabanakman
  Play Store ' a uygulama atarken 64 bit hatası crowlin 15 1.090 29-05-2019, Saat: 11:50
Son Yorum: crowlin
  Delphi 10.3 FMX Android Sdk Dosya Yolu Belirtme Hatası xenginyigit 3 441 19-05-2019, Saat: 05:20
Son Yorum: xenginyigit



Konuyu Okuyanlar: 1 Ziyaretçi