Konuyu Oyla:
  • Derecelendirme: 0/5 - 0 oy
  • 1
  • 2
  • 3
  • 4
  • 5
android sdk sorunu
#1
selamlar
sdk managerde 29 nolu api kurulu şu anda ama bana 18 numaralı api lazım
download ettikten sonra tools ->option da android 25.2.5 32.bit kurulu ve çalışıyor
ama donload ettiğim sdk add dşyerek yukleme ye çalıştığımda unlem işareti cıkıyor ve 18 nolu apiyi kullanamıyorum
kullanacağım cihaz cok eskı olduğu ıcın 18 api kullanın dedıler ama derleyemedım acıl yardım lütfen.

18 nolu apinin ful sdk sı varsa oda ısımı gorur ndk sını buldum ama ındırdığım hıc bı sdk tam değil sanırım unlem verıyor
Cevapla
#2
Merhaba,
Önce uyarı ile başlayalım. 
Desteklemeye çalıştığınız SDK, Dephi XE5 ile Delphi 10.2 Tokyo sürümleri arasındaki Delphi sürümlerini kapsayacak. Delphi 10.3 Rio ve sonraki sürümler için API 18 desteği olmayacak.
Daha da önemlisi Android bu SDK sürümünü ne zamana kadar destekleyecek.  

Çözüm için;
1- AndroidManifest.template.xml dosyasındaki minSdkVersion ve targetSdkVersion sürümlerini aşağıdaki gibi düzeltin.
<uses-sdk android:minSdkVersion="18" android:targetSdkVersion="18" />
2- Android Tools üzerinden API Level 18 SDK platformunu yükleyin.
3- Delphi IDE'si üzerinden Tools > Options > Deployment > SDK Manager penceresini açın ve herhangi bir Android SDK versiyonunu seçin.
4- SDK, JDK ve NDK sekmelerinde gördüğünüz tüm ünlem işaretli alanları düzeltin.
Bu alanların nasıl düzeltileceği daha önce formda birkaç konu başlığı altında anlatıldı. Aynı zamanda Yeni Kaynak Kitabımızdada bu konuda geniş bilgi yer almaktadır. 

   

5- Project Manager penceresinde, Target Platforms > Android 32-bit > Libraries üzerinde sağ tuşa basın ve Revert system Files to Default menüsünü seçin.
6- Project Manager penceresinde, Proje adı üzerinde sağ tuşa tıklayın ve Clean menüsünü seçin.
Yukarıdaki işlem adımlarını sorunsuz gerçekleştirdiğinizde, projeniz yalnızca Android API Level 18 de çalışacaktır.
While true do; Hayat döngüsü, kısır değildir! Yapılan bir yanlış, o döngünün dışına çıkmanızı sağlayacaktır.
WWW
Cevapla
#3
(21-07-2020, Saat: 15:25)Fesih ARSLAN Adlı Kullanıcıdan Alıntı: Merhaba,
Önce uyarı ile başlayalım. 
Desteklemeye çalıştığınız SDK, Dephi XE5 ile Delphi 10.2 Tokyo sürümleri arasındaki Delphi sürümlerini kapsayacak. Delphi 10.3 Rio ve sonraki sürümler için API 18 desteği olmayacak.
Daha da önemlisi Android bu SDK sürümünü ne zamana kadar destekleyecek.  

Çözüm için;
1- AndroidManifest.template.xml dosyasındaki minSdkVersion ve targetSdkVersion sürümlerini aşağıdaki gibi düzeltin.
<uses-sdk android:minSdkVersion="18" android:targetSdkVersion="18" />
2- Android Tools üzerinden API Level 18 SDK platformunu yükleyin.
3- Delphi IDE'si üzerinden Tools > Options > Deployment > SDK Manager penceresini açın ve herhangi bir Android SDK versiyonunu seçin.
4- SDK, JDK ve NDK sekmelerinde gördüğünüz tüm ünlem işaretli alanları düzeltin.
Bu alanların nasıl düzeltileceği daha önce formda birkaç konu başlığı altında anlatıldı. Aynı zamanda Yeni Kaynak Kitabımızdada bu konuda geniş bilgi yer almaktadır. 



5- Project Manager penceresinde, Target Platforms > Android 32-bit > Libraries üzerinde sağ tuşa basın ve Revert system Files to Default menüsünü seçin.
6- Project Manager penceresinde, Proje adı üzerinde sağ tuşa tıklayın ve Clean menüsünü seçin.
Yukarıdaki işlem adımlarını sorunsuz gerçekleştirdiğinizde, projeniz yalnızca Android API Level 18 de çalışacaktır.

hocam selamlar
orangeui anlatımınız inanılmaz ilgimi çekti ve bütün uyugulamalrımda kullanıyorum bu konuda teşekür ederim

sdk ila alakalı elimde 4.3 versiyon barkod okuyan ve yazıcısı olan bır cıhaz var malesef bu cıhaza uygun bır derleme yapmam lazım
şua na vwmvare berllini kurdum sdk api 18 için için download yapıyor tek sorum şu

   


tekrar selam
birde bu cıhaz ın yazıcısını nasıl kullanırım nasıl print yaparım
Cevapla
#4
(23-07-2020, Saat: 02:49)uersoy Adlı Kullanıcıdan Alıntı:
(21-07-2020, Saat: 15:25)Fesih ARSLAN Adlı Kullanıcıdan Alıntı: Merhaba,
Önce uyarı ile başlayalım. 
Desteklemeye çalıştığınız SDK, Dephi XE5 ile Delphi 10.2 Tokyo sürümleri arasındaki Delphi sürümlerini kapsayacak. Delphi 10.3 Rio ve sonraki sürümler için API 18 desteği olmayacak.
Daha da önemlisi Android bu SDK sürümünü ne zamana kadar destekleyecek.  

Çözüm için;
1- AndroidManifest.template.xml dosyasındaki minSdkVersion ve targetSdkVersion sürümlerini aşağıdaki gibi düzeltin.
<uses-sdk android:minSdkVersion="18" android:targetSdkVersion="18" />
2- Android Tools üzerinden API Level 18 SDK platformunu yükleyin.
3- Delphi IDE'si üzerinden Tools > Options > Deployment > SDK Manager penceresini açın ve herhangi bir Android SDK versiyonunu seçin.
4- SDK, JDK ve NDK sekmelerinde gördüğünüz tüm ünlem işaretli alanları düzeltin.
Bu alanların nasıl düzeltileceği daha önce formda birkaç konu başlığı altında anlatıldı. Aynı zamanda Yeni Kaynak Kitabımızdada bu konuda geniş bilgi yer almaktadır. 



5- Project Manager penceresinde, Target Platforms > Android 32-bit > Libraries üzerinde sağ tuşa basın ve Revert system Files to Default menüsünü seçin.
6- Project Manager penceresinde, Proje adı üzerinde sağ tuşa tıklayın ve Clean menüsünü seçin.
Yukarıdaki işlem adımlarını sorunsuz gerçekleştirdiğinizde, projeniz yalnızca Android API Level 18 de çalışacaktır.

hocam selamlar
orangeui anlatımınız inanılmaz ilgimi çekti ve bütün uyugulamalrımda kullanıyorum bu konuda teşekür ederim

sdk ila alakalı elimde 4.3 versiyon barkod okuyan ve yazıcısı olan bır cıhaz var malesef bu cıhaza uygun bır derleme yapmam lazım
şua na vwmvare berllini kurdum sdk api 18 için için download yapıyor tek sorum şu




tekrar selam
birde bu cıhaz ın yazıcısını nasıl kullanırım nasıl print yaparım

Merhaba,
Rica ederim.
Delphi FMX desteği olan sürümlerden gördüğüm kadarıyla en çok bug'u olan sürümü (Delphi 10.1 Berlin) kullanıyorsunuz. Android 4.3 SDK ile uygulama geliştirmek için Delphi 10.2.3 (Update 3) Tokyo sürümünü kullanın. 
Android API level 18 geliştirme ortamı için
1- Android Tools aracından, Android SDK Tools, Android SDK platform-tools ve Android SDK build-tools'un 'un en güncel sürümlerini yükleyin.  

   

2- Android Tools aracından, Android 4.3.1 (API 18) altındaki SDK platform'u yükleyin.

   

3- Son olarak SDK Manager penceresinde aşağıda gösterilen alanları yüklediğiniz SDK sürümleri ile değiştirin. 

   

Not: Tüm istekleri tek başlık altında toplamayın lütfen. Yazıcı ile ilgili yardım talebiniz için yeni bir konu açın.
While true do; Hayat döngüsü, kısır değildir! Yapılan bir yanlış, o döngünün dışına çıkmanızı sağlayacaktır.
WWW
Cevapla
#5
selamlar hocam
api level i 18 e çekmeye gerek varmı alt versiyonu desteklermı bu şekilde
Cevapla
#6
(25-07-2020, Saat: 01:42)uersoy Adlı Kullanıcıdan Alıntı: selamlar hocam
api level i 18 e çekmeye gerek varmı alt versiyonu desteklermı bu şekilde

Projede farkında olarak veya olmadan API level 18 üstü bir metod/function kullanmanız durumunda, Android 4.x sürümlü bir cihazda uygulama kırılacaktır.
Uygulamanın yalnızca API level 18'e özgü olduğunu yazmıştınız; bu nedenle yalnızca API level 18'de çalışmanızda fayda var.
While true do; Hayat döngüsü, kısır değildir! Yapılan bir yanlış, o döngünün dışına çıkmanızı sağlayacaktır.
WWW
Cevapla


Konu ile Alakalı Benzer Konular
Konular Yazar Yorumlar Okunma Son Yorum
  Uygulama imzalama sorunu[ÇÖZÜLDÜ] codder71 5 212 22-09-2020, Saat: 13:12
Son Yorum: codder71
  10.4 api sorunu codder71 1 142 12-09-2020, Saat: 19:53
Son Yorum: mcuyan
  Android Pdf Dosya Oluşturma ahmet6513 0 98 10-09-2020, Saat: 00:40
Son Yorum: ahmet6513
  android ve ios dan navigasyon açmak uersoy 9 416 09-09-2020, Saat: 17:27
Son Yorum: mcuyan
  [ ÇÖZÜLDÜ ] Play Console İmza Sorunu ? Delphi 10.3 Mr.Developer 12 4.386 07-09-2020, Saat: 12:52
Son Yorum: codder71



Konuyu Okuyanlar: 1 Ziyaretçi