Konuyu Oyla:
  • Derecelendirme: 5/5 - 1 oy
  • 1
  • 2
  • 3
  • 4
  • 5
Play Store Cihaz Kataloğu
#1
Arkadaşlar merhaba. Play Store yüklediğimiz uygulama bazı cihazları desteklemiyor. Apk yı direk cihazlara yüklebiliyorum ancak play store de arama yapmak istediğimizde çıkmıyor direk linkten yüklemek istediğimizde bu öğe cihazınızla uyumlu değil diyerek yükleyemiyorum. Bu cihazları nasıl uyumlu hale getirebilirim.

Embarcadero  site şöyle bir çözümden bahsetmişler denedim ama yine olmadı. 

http://docwiki.embarcadero.com/RADStudio...oid_Device




AyYbbz.jpg
Cevapla
#2
Merhaba,
Android platformunun uygulama ayarları ve erişebileceği donanımsal izinlerinin tümü AndroidManifest dosyasında saklanıyor.
Tahminimce Android 4.1 ve daha alt sürümleri, bu konfigürasyon dosyasındaki bazı özellikleri kullanamıyor. Doğal olarak, desteklenmiyor.
AndroidManifest içerisinde minSdkVersion parametresi ile hedef platform SDK gereksinimi yeniden düzenlenebilir. Fakat hedeflenen düşük SDK sürümlerinde desteklenmeyen bir çok özellik uygulamanın çalışma sırasında kırılmasına veya siyah ekranda kalmasına sebep olacaktır.
Embarcadero'nun destek verdiği Android SDK sürümleri:  Android Devices Supported for Application Development
While true do; Hayat döngüsü, kısır değildir! Yapılan bir yanlış, o döngünün dışına çıkmanızı sağlayacaktır.
WWW
Cevapla
#3
Cihazın 5 farklı modeli var 1 tanesi destekliyor diğer 4 tanesinde desteklenmiyor. Cihaza direk apk doyasını yükleyerek çalıştırdığımda herhangi bir sorunla karşılaşmadım. minSdkVersion 14 yazıyor burda bir değişiklik yaparak bu sorunu aşabilirmiyim ?
Cevapla
#4
Google Play Store, yükleme yapmadan önce kayıtlı cihaz SDK'sı ile yüklenmiş olan uygulama SDK'sının birbirlerini destekleyip desteklemediğine bakıyor. Bununla birlikte açıklamadığı (güvenlik gerekçeleri) bir çok parametreler de vardır.

Örnek bir cihaz destek tablosu:

2017-09-15_09-01-55.png

Cihaza doğrudan Apk dosyasını yüklediğinizde, yukarıda belirttiğim gereksinimleri karşılayıp karşılamadığı kontrol edilmiyor. Bu nedenle doğrudan kurulum yapılabiliyor. Google'ın bu cihaz desteklenmiyordan kastı, yaşanabilecek muhtemel sorunların önüne geçmektir. Aslında bu tavrı biz geliştiricileri koruyor. Oluşan tüm hatalar geliştiriciye mal edilir ve uzun vadede güvensizlik oluşur.
minSdkVersion parametresini değiştirdiğinizde, Google Play'den düşük sürümlü, desteklenmeyen SDK'ya sahip cihazlar tarafından yüklenebileceği manasına gelmiyor. Yukarıda da belirttiğim gibi Google'ın bir cihazı destekleyip desteklemediğini tespit etmek için kullandığı bir çok parametresi vardır.
While true do; Hayat döngüsü, kısır değildir! Yapılan bir yanlış, o döngünün dışına çıkmanızı sağlayacaktır.
WWW
Cevapla
#5
Anladım teşekkür ederim.
Cevapla
#6
Merhaba,

Muhtemelen projenizin izinleri hususunda bir problem oluşmuştur. Varsayılan olarak FMX projenizde telefonlara has bazı özellikler talep ediliyor. (Telefon modülü, SMS Modülü vb.) Bu modüller tablet türündeki cihazların donanımsal yapısına uymadığı zaman desteklenmeyen cihaz olarak nitelendirildikleri için Google Play üzerinden uygulamayı aradığınızda cihazınıza uyumlu bir uygulama olmadığı bilgisini alıyorsunuz.

Çözüm;

Project > Options > Uses Permissions kısmına girin. Proje içinde kullanmadığınız/ihtiyaç duymadığınız özelliklere dair işaretlenmiş (checked) olan izinleri kaldırın. Uygulamanız %90 ihtimalle Fesih Bey'in attığı görseldeki gibi birçok cihazla uyumlu hale gelecektir.

İyi günler.
Cevapla
#7
Konuyla ilgili bir soru: Bildirğiniz üzere And SDK managerde son çıkan AND versiyonlarının SDK ları yayınlanıyor. Şunnu öğrenmek istiyorum: En son SDK lar eski telefonları destekliyormu.. yoksa en alt düzey SDK ları kullanıp Yeni ANd telefonları mı kullanmamız gerkeiyor. Yani SDK manager daki versiyonlar konusudna bilgi almak istiyorum Smile
Cevapla
#8
(27-09-2017, Saat: 17:29)mcuyan Adlı Kullanıcıdan Alıntı: Konuyla ilgili bir soru: Bildirğiniz üzere And SDK managerde son çıkan AND versiyonlarının SDK ları yayınlanıyor. Şunnu öğrenmek istiyorum: En son SDK lar eski telefonları destekliyormu.. yoksa en alt düzey SDK ları kullanıp Yeni ANd telefonları mı kullanmamız gerkeiyor. Yani SDK manager daki versiyonlar konusudna bilgi almak istiyorum Smile

Yazmış olduğum uygulamaları genellikle Android API 5, 6 ve 7 sürümlerinin tümünde test ediyorum. Sanırım @abdullah ILGAZ'ında belirttiği nedenlerden dolayı; uygulama tüm Android sürümlerinde sorunsuz çalışıyor (Android 4.1 ve üzeri olması kaydıyla tabi. Embarcadero'nun alt destek limiti). 
Aşağıda geliştirmiş olduğum bir uygulamanın gerçek cihaz sayıları gösteriliyor. Uygulama yaklaşık olarak bir aydır kullanılıyor. Herhangi bir olumsuz geri dönüş olmadı. 

2017-09-27_17-38-39.png
While true do; Hayat döngüsü, kısır değildir! Yapılan bir yanlış, o döngünün dışına çıkmanızı sağlayacaktır.
WWW
Cevapla
#9
(27-09-2017, Saat: 17:43)Fesih ARSLAN Adlı Kullanıcıdan Alıntı: Yazmış olduğum uygulamaları genellikle Android API 5, 6 ve 7 sürümlerinin tümünde test ediyorum. Sanırım @abdullah ILGAZ'ında belirttiği nedenlerden dolayı; uygulama tüm Android sürümlerinde sorunsuz çalışıyor (Android 4.1 ve üzeri olması kaydıyla tabi. Embarcadero'nun alt destek limiti). 
Aşağıda geliştirmiş olduğum bir uygulamanın gerçek cihaz sayıları gösteriliyor. Uygulama yaklaşık olarak bir aydır kullanılıyor. Herhangi bir olumsuz geri dönüş olmadı.

Merhaba,

intel işlemcili android cihazlarda durum nedir? (çalışma ve performans olarak)
Cevapla
#10
(27-09-2017, Saat: 17:52)meko Adlı Kullanıcıdan Alıntı:
(27-09-2017, Saat: 17:43)Fesih ARSLAN Adlı Kullanıcıdan Alıntı: Yazmış olduğum uygulamaları genellikle Android API 5, 6 ve 7 sürümlerinin tümünde test ediyorum. Sanırım @abdullah ILGAZ'ında belirttiği nedenlerden dolayı; uygulama tüm Android sürümlerinde sorunsuz çalışıyor (Android 4.1 ve üzeri olması kaydıyla tabi. Embarcadero'nun alt destek limiti). 
Aşağıda geliştirmiş olduğum bir uygulamanın gerçek cihaz sayıları gösteriliyor. Uygulama yaklaşık olarak bir aydır kullanılıyor. Herhangi bir olumsuz geri dönüş olmadı.

Merhaba,

intel işlemcili android cihazlarda durum nedir? (çalışma ve performans olarak)

Tabiri caiz ise; tam da adamına sordunuz. Smile
Yaklaşık üç yıldır Asus Zenfone 5 telefon kullanıyorum.  (Yanlış bilmiyorsam mobil cihazlarda ilk intel işlemci kullanan Asus oldu)
Yapmış veya indirmiş olduğum yüzlerce uygulamayı test ediyorum. Intel işlemci nedeniyle oluşan herhangi bir hata ile karşılaşmadım. Hız konusunda da diğer Andoid cihazlarla aynı olduğunu gözlemledim.
Hatırlarsanız, Intel işlemcili mobil cihazlarda uygulamaların çalışması için Deployment penceresinde küçük bir konfigürasyon yapılıyordu. Delphi Berlin ve sonraki sürümünde bu sorun da çözüldü. 

Örnek Intel işlemcili telefonum;
Screenshot_2017-09-27-18-08-16.png
While true do; Hayat döngüsü, kısır değildir! Yapılan bir yanlış, o döngünün dışına çıkmanızı sağlayacaktır.
WWW
Cevapla


Konu ile Alakalı Benzer Konular
Konular Yazar Yorumlar Okunma Son Yorum
  Play console SDK 28 ? Mr.Developer 0 123 11-05-2020, Saat: 17:45
Son Yorum: Mr.Developer
  Play Store 'un Güncellemesin de SqLite Veritabanında kayıp yaşanır mı? 41linea41 0 387 01-01-2020, Saat: 13:01
Son Yorum: 41linea41
Smile Google Play a uygulama yükleniyor mu? crowlin 3 598 11-12-2019, Saat: 16:01
Son Yorum: mamcak
  Google Play Yayınlama Sorunu ikurt07 1 533 10-12-2019, Saat: 23:16
Son Yorum: ikurt07
  Google Play Yükleme Sertifikası ikurt07 6 1.527 07-12-2019, Saat: 00:14
Son Yorum: mamcak



Konuyu Okuyanlar: 1 Ziyaretçi