Konuyu Oyla:
  • Derecelendirme: 4/5 - 2 oy
  • 1
  • 2
  • 3
  • 4
  • 5
Emulatorde INSTALL_FAILED_NO_MATCHING_ABIS hatası
#1
Merhaba projeyi android emulator üzerinde çalıştırmak istediğimde "INSTALL_FAILED_NO_MATCHING_ABIS: Failed to extract native libraries, res=-113" şeklinde hata alıyorum. Nasıl düzeltebilirim ?



oVQ3Do.png
Cevapla
#2
Sisteminizde adb driver yüklü mü? Değilse yüklemeniz gerekmektedir. Buradan ulaşabilirsiniz.
Bazen daha ileriye ulaşmak için bir kaç adım geri gitmek mecburidir. Çünkü en ileri sıçrayışlar iki adım geriden başlar.
Cevapla
#3
Merhaba,
Android platformu seçili iken, Project > Deployment manager penceresinin ekran görüntüsünü paylaşabilir misiniz?
While true do; Hayat döngüsü, kısır değildir! Yapılan bir yanlış, o döngünün dışına çıkmanızı sağlayacaktır.
WWW
Cevapla
#4
(23-05-2018, Saat: 15:13)ihalilcoban Adlı Kullanıcıdan Alıntı: Sisteminizde adb driver yüklü mü? Değilse yüklemeniz gerekmektedir. Buradan ulaşabilirsiniz.

Yüklü değildi yükledim ama sorun devam ediyor

(23-05-2018, Saat: 15:18)Fesih ARSLAN Adlı Kullanıcıdan Alıntı: Merhaba,
Android platformu seçili iken, Project > Deployment manager penceresinin ekran görüntüsünü paylaşabilir misiniz?

Fesih Bey ekran görüntüsü bu şekilde : 



aYqXNd.png
Cevapla
#5
Deployment konfigürasyonunda herhangi bir sorun görünmüyor. 
Tahminimce AVD Manager aracılığıyla oluşturduğunuz sistem image'ında bir sorun olabilir.  
1- Android Sistem Image'ını (Örnek) yeniden yükleyin.
2- AVD Manager penceresinde daha önce oluşturduğunuz emülatörü silin.
3- Yeni Image ile emülatörü yeniden oluşturun.
While true do; Hayat döngüsü, kısır değildir! Yapılan bir yanlış, o döngünün dışına çıkmanızı sağlayacaktır.
WWW
Cevapla
#6
(23-05-2018, Saat: 17:41)Fesih ARSLAN Adlı Kullanıcıdan Alıntı: Deployment konfigürasyonunda herhangi bir sorun görünmüyor. 
Tahminimce AVD Manager aracılığıyla oluşturduğunuz sistem image'ında bir sorun olabilir.  
1- Android Sistem Image'ını (Örnek) yeniden yükleyin.
2- AVD Manager penceresinde daha önce oluşturduğunuz emülatörü silin.
3- Yeni Image ile emülatörü yeniden oluşturun.

Fesih Bey dediklerinizi yaptım sorun düzelmedi. 
AVD manager üzerinden CPU seçimini ARM(armeabi-v7a) seçince çalıştı. CPU olarak intel kullanamıyor muyuz ?
Cevapla
#7
(23-05-2018, Saat: 23:19)ybelen Adlı Kullanıcıdan Alıntı:
(23-05-2018, Saat: 17:41)Fesih ARSLAN Adlı Kullanıcıdan Alıntı: Deployment konfigürasyonunda herhangi bir sorun görünmüyor. 
Tahminimce AVD Manager aracılığıyla oluşturduğunuz sistem image'ında bir sorun olabilir.  
1- Android Sistem Image'ını (Örnek) yeniden yükleyin.
2- AVD Manager penceresinde daha önce oluşturduğunuz emülatörü silin.
3- Yeni Image ile emülatörü yeniden oluşturun.

Fesih Bey dediklerinizi yaptım sorun düzelmedi. 
AVD manager üzerinden CPU seçimini ARM(armeabi-v7a) seçince çalıştı. CPU olarak intel kullanamıyor muyuz ?

Yaptığınız işlem dediklerim arasında vardı (1. Adım örnek linki)
Kullandığınız API level'e uygun bir x86 image yüklerin. Emulator oluştururken de x86 image'ınızı seçin.
Ayrıca Delphi 10 ve altı bir sürüm için Deployment manager'da küçük bir konfigürasyon yapmanız gerekecek.
While true do; Hayat döngüsü, kısır değildir! Yapılan bir yanlış, o döngünün dışına çıkmanızı sağlayacaktır.
WWW
Cevapla
#8
(24-05-2018, Saat: 02:09)Fesih ARSLAN Adlı Kullanıcıdan Alıntı:
(23-05-2018, Saat: 23:19)ybelen Adlı Kullanıcıdan Alıntı: Fesih Bey dediklerinizi yaptım sorun düzelmedi. 
AVD manager üzerinden CPU seçimini ARM(armeabi-v7a) seçince çalıştı. CPU olarak intel kullanamıyor muyuz ?

Yaptığınız işlem dediklerim arasında vardı (1. Adım örnek linki)
Kullandığınız API level'e uygun bir x86 image yüklerin. Emulator oluştururken de x86 image'ınızı seçin.
Ayrıca Delphi 10 ve altı bir sürüm için Deployment manager'da küçük bir konfigürasyon yapmanız gerekecek.

Merhaba, 

Dediğiniz gibi x86 yükledim. Deployment manager için nasıl bir ayarlama yapmam gerekiyor
Cevapla
#9
(26-05-2018, Saat: 12:37)ybelen Adlı Kullanıcıdan Alıntı:
(24-05-2018, Saat: 02:09)Fesih ARSLAN Adlı Kullanıcıdan Alıntı: Yaptığınız işlem dediklerim arasında vardı (1. Adım örnek linki)
Kullandığınız API level'e uygun bir x86 image yüklerin. Emulator oluştururken de x86 image'ınızı seçin.
Ayrıca Delphi 10 ve altı bir sürüm için Deployment manager'da küçük bir konfigürasyon yapmanız gerekecek.

Merhaba, 

Dediğiniz gibi x86 yükledim. Deployment manager için nasıl bir ayarlama yapmam gerekiyor

 Yanlış değilsem libnative.so tiklerini kaldırmak gerekiyor. Eğer @Fesih ARSLAN hocamın dediği olay libnative ise; bunun için bir videom vardı. Intel işlemciler için geçmişte sorun yaşamıştım ve sonuç olarak bu çözümü vermişlerdi. Attığım video kaynaklarını inceleyerek bir fixleme yaparsanız daha sağlıklı sonuç elde edersiniz demiş sanırsam Fesih hocam.

Video:

Delphi'de Android Programlama - Deployment Seçimleri - BlueStacks Emulator Kullanma - Ders 14

Yazılı Kaynak[Marco reis yazmış]:

Running Delphi Applications on Android Intel

Kolay gelsin.
Yazılım Topluluğumuz -> Tıklayın
Kişisel Tanıtım Sitem -> Tıklayın
20 y/o, sadece öğrenmeye odaklanmış, insancık..
WWW
Cevapla
#10
(26-05-2018, Saat: 23:57)hyperxman Adlı Kullanıcıdan Alıntı:
(26-05-2018, Saat: 12:37)ybelen Adlı Kullanıcıdan Alıntı: Merhaba, 

Dediğiniz gibi x86 yükledim. Deployment manager için nasıl bir ayarlama yapmam gerekiyor

 Yanlış değilsem libnative.so tiklerini kaldırmak gerekiyor. Eğer @Fesih ARSLAN hocamın dediği olay libnative ise; bunun için bir videom vardı. Intel işlemciler için geçmişte sorun yaşamıştım ve sonuç olarak bu çözümü vermişlerdi. Attığım video kaynaklarını inceleyerek bir fixleme yaparsanız daha sağlıklı sonuç elde edersiniz demiş sanırsam Fesih hocam.

Video:

Delphi'de Android Programlama - Deployment Seçimleri - BlueStacks Emulator Kullanma - Ders 14

Yazılı Kaynak[Marco reis yazmış]:

Running Delphi Applications on Android Intel

Kolay gelsin.

Merhaba hocam,

Videonuzu daha önceden izlemiştim fakat yine çözüm olmadı. Deployment kısmında x86 ya ait bir tanım bulunmuyor. Sorun bundan kaynaklanıyor oalbilir mi ? qv9VMR.png
Cevapla


Konu ile Alakalı Benzer Konular
Konular Yazar Yorumlar Okunma Son Yorum
  Android derleme hatası arsl01 0 53 Dün, Saat: 23:42
Son Yorum: arsl01
  IOS Simulator "Unable to create process: /Applications/PAServer-20.0.app/" Hatası elixir84 7 521 04-06-2020, Saat: 02:28
Son Yorum: elixir84
  Android deployment E0004 PAClient Hatası behcet.tolga 2 394 23-03-2020, Saat: 16:42
Son Yorum: behcet.tolga
  TabControl delete adres hatası Kerembacioglu 5 803 09-03-2020, Saat: 23:27
Son Yorum: kodamelesi
  Socket error #110. connection time out hatası hbulus 6 985 05-02-2020, Saat: 13:11
Son Yorum: adelphiforumz



Konuyu Okuyanlar: 1 Ziyaretçi